The Nissan Club banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello guys,
I have 2009 Nissan Altima. It is 183000km. It runs very well. Since last two months, it losses acceleration for less than a second and gives a jurk. No engine noise, no indication of any engine missing. Just a small jurk. It happens once a day, once a week or once every trip. It is just very random. But it happens when I’m pushing accelerator.
Could someone advise what is most possible problem? I didn’t visit mechanic as he said that he needs to observe the problem to diagnose and the problem is just very random.
 

·
Registered
Joined
·
1,963 Posts
Hello guys,
I have 2009 Nissan Altima. It is 183000km. It runs very well. Since last two months, it losses acceleration for less than a second and gives a jurk. No engine noise, no indication of any engine missing. Just a small jurk. It happens once a day, once a week or once every trip. It is just very random. But it happens when I’m pushing accelerator.
Could someone advise what is most possible problem? I didn’t visit mechanic as he said that he needs to observe the problem to diagnose and the problem is just very random.
But those of us on this forum are able to guess what the problem is?
 

·
Registered
Joined
·
40 Posts
Check the resistance on your fuel injectors. Use a digital multimeter and touch the leads to the two prongs on the injectors. (set it to the same range as the correct range you are hoping to see (the 20 Ohms setting on the DMM).
Look in the service manual for the correct resistance (Ohms) range. If it is over, change that injector.
If it were jerking consistantly, I would check your knock sensor or EGR valve. Do a search for "how to diagnose a bad ___" for these two items if you are curious.
 
1 - 3 of 3 Posts
Top