The Nissan Club banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
theres a noise coming from th left of the engine block its like a metal hitting another metal you oly hear it when thecar is on park but when you accelerte you dont hear it anymore can anyonehelp
 

·
Registered
Joined
·
1,083 Posts
omg..is it like a slight metal clanking noise while in neutral too? i've been hearing that shit and i cant find where it is. only at idle..right??? but once you hit the gas to about 1000rpm..its gone..right?
 

·
I am the universe.
Joined
·
1,034 Posts
It may not be the timing chain cover itself, if you have a pre 1995 (or 1994) altima there was a cover over the timing chain that does nothing but cause this noise... Remove your valve cover and take the cover off... Replace the valve cover (with possibly a new gasket if you need it) and see if the sound is still there...

Remember a timing chain fix at a dealer or mechanic will cost you damn near 1000 dollars.
 

·
Registered
Joined
·
234 Posts
My problem was the timing chain upper guide.

Peterson told me that a while back.

The noise is like a "marble in a can"

The noise was only at idle and as soon as the RPM's go past 1000 the noise was gone.

I opened the valve cover removed the upper guide, installed new gaskets for the valve cover and the noise was gone !!

ank

:D
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top