The Nissan Club banner

21 - 30 of 30 Posts

·
552nd Aircraft Maint. Sq.
Joined
·
363 Posts
Yes, I would check all of them. I'm sorry I can't help you much more after that, but I'm sure someone else will be able to.
 

·
Registered
Joined
·
1 Posts
Does anyone know what the fix is for the o/d light blinking 16 times at warm start-up. My ecu is throwing 12-5 (line pressure solenoid) but the car drives normally. The dealer had the car for two days and didn't do jack (at least there was no charge for the diagnostics).

Could this be a computer error? I have reset it several times but it returns within days.
 

·
X Factor
Joined
·
546 Posts
Here's a run down of my car doing the same thing:

Last year the damn thing started to slam the car into the next gear at 4000 RPM and would not shift before then and would not downshift either. But if you turned the car off and back on, even while driving down the road, the thing would reset and work fine. The OD light would sometimes flash 16 times and every once in a while the Check Engine light would come on and flash too. Nissan says the check engine light isn't supposed to flash it is supposed to stay on and a code is stored until reset, they have witnessed the Engine light flashing and swear it's impossible and no code is ever stored. The TCU and ECU have both been replaced. It has been to 3 different Nissan dealerships, 5 different import automotive stores, and 4 transmission shops in the last year and the car even did had the problem for them! But nobody knows the cause of the probem. Nissan says that 16 flashes of the OD light means "Jack Shit" to them and that they don't have a clue as to the problem. The car stopped having this problem for about 3 months and has misteriously reappeared in the last 2 weeks. It only does it about twice a day and can be reset by turning the egnition off and back on even while doing 80mph with the car in drive. Nissan suggested just selling the car when it was working properly!!!! This sucks like no other, and nobody seems to have the answer. One mechanic traded me his new car to drive for a week while he drove my car around to attempt to find the problem because it fascinated him in some weird way! Good luck and let me know if you find a solution!

Sorry to be the bearer of bad news,

Scott
 

·
X Factor
Joined
·
546 Posts
^^ Oh yeah, the transmission has been taken apart and determined that nothing is mechanically wrong, as well as having an engine swap 6 months ago. Two places have even blamed the problem on my Clifford alarm/remote start system.
 

·
Resident Titans Fan
Joined
·
1,395 Posts
i almost wanna say that fatdaddy is makin this stuff up as he goes, lol...props on the know-how
 

·
Registered
Joined
·
1 Posts
My OD light blinks 16 times on startup. With the OD on my x trail is extremely lazy and doesn't down shift when driving, I have to turn off the OD or put in 2nd gear. Tried ECU, TCM , Speed Sensor same result.
It changes normally though without an issue.
 
21 - 30 of 30 Posts
Top