The Nissan Club banner
1 - 10 of 10 Posts

·
H.N.I.C.
Joined
·
2,666 Posts
you're prob gonna hav to end up replacin' the distributor
i know of quite a few altima owners who have 95s n b4 who had a prob wit the O ring....
jus make sure that the valve cover gasket is changed wen u do get it changed...
Pep boys didn't do mine n mines been leakin' for a minute
those bastardz..
:(
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
looks good

changed o-ring-pretty straight foward job-20 minutes tops-did not have to touch valve cover to change. five days later and the car is still running good, also seems to be starting much better. As for changing the distributer anyway-the o-ring was $3.00 and a rebuilt distributor was quoted in the range of $250.00 to $300.00 plus a core fee. I think I'll see how this turns out.
By the way-douched the crap out of the interior of the distributer with contact cleaner and let dry-I think this was crucial at removing all the oil residue-will do follow up after my trip to myrtle beach in april--
gman1185
 

·
Registered
Joined
·
6 Posts
I had similar problem about a half a year ago. Cleaning a distributor lasted for about 2 weeks. Then it started leaking again. After that I've replaced it ($130 aftermarket at Discount Auto Parts). No problem since.

Janusz
 

·
good one Fonzie
Joined
·
5,965 Posts
this is the same problem that happened to me during mardi gras. I had mine replaced...remanufactured one from auto-zone with a lifetime warranty. Cost $135 after the $50 core.

But something else you may want to do is replace your valve cover gasket. Mine was bad and I think that's why I had oil in it too. I had oil everywhere, and that is what I did to help take care of the problem
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top