The Nissan Club banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Greetings,

Here are the symptoms...

1) I've had a power steering leak for 6 months. I've added a quart every month, and I just topped it off.

2) A couple weeks ago, there was a ticking from my engine. It speeds up when I speed up, and continues at idle. It has gotten more pronounced over the last few weeks.

3) I just went to get an oil change because I heard that can alleviate tensioner problems temporarily, and when I got home a couple hours later, after driving say 20 miles, I started to make a sharp turn into my uphill driveway, and a loud clanging noise began to occur. The car did not jolt or anything, but when I backed up and tried it again, even a small turn in that direction did the same thing. I tried the wheel in the other way, and it seemed fine. The power steering fluid is not low. Slightly low yes but not low.

I should also add that when they had the car up on the rack, they mentioned it was a power steering hose leaking a lot.

Whether it was timing, or they yanked something, I'd love to hear the possible things to look for. What should I check first? Power steering pump? Tensioner? Or possibly both at the same time?

Thanks a bunch

Adam

2006 3.5L SE-R Altima
 

·
Registered
Joined
·
443 Posts
To eliminate the power steering system, remove the front belt for the power steering from the engine. Start the engine and listen for the loud clanging noise; move the car around a bit and turn the steering wheel a little to see if there is any noise.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
All in on the PS pump.
 
1 - 3 of 3 Posts
Top