The Nissan Club banner

1 - 15 of 15 Posts

·
Zach Schnieders
Joined
·
108 Posts
Discussion Starter #1
does anyone have a good wire diagram for a 2003 nissan altima non bose stock radio. Im installing an aftermarket radio and i cant figure out the wiring
I have the wire adapters but i still need to match the wires from the new radio with the adapter wires
 

·
12-Volt Tech
Joined
·
8 Posts
Which side do you need?

Are you looking for factory nissan wire colors, or the standardised aftermarket harness colors?

anyways Nissan side should be
LF SPEAKER blu/wht - blu/red
RF SPEAKER wht/blk - blu/blk
LR SPEAKER grn/yel - blk/yel
RR SPEAKER blue - red
RADIO 12V yellow/green
RADIO GROUND
RADIO SWITCH purple
RADIO ILLUMINATE red/blue
POWER ANTENNA green

Aftermarket side should be

Wiring Harness Color Standards - Knowledge Base
 

·
Zach Schnieders
Joined
·
108 Posts
Discussion Starter #3
What about the wiring for steering wheel controls?
the radio i got has wires for steering wheel controls
what colors are they?
 

·
Moderator
Joined
·
623 Posts
moving this to the car audio forum. the car audio gurus should be able to help you out a little bit more
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,885 Posts
one speaker, or all of them?
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,885 Posts
All of them
And does the radio display function as normal? Do you have BOSE audio in your car? You should start your own thread BTW.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,885 Posts
If the speaker wire harness wired up revers would it matter
No, your audio would just sound a bit muffled. Does your question mean there's been a recent 'surgery' in the car's audio system?

To me, loss of all audio output, would infer that the amplifier is damaged or not receiving power. If the amp is internal to the radio, then the radio unit needs replacing--if all else is functioning as you say.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,885 Posts
Your fault lies inside your radio unit. Shortest path to fix is to replace with a used unit. There is no 'external factory amp' to even consider powering...it's all integral inside the radio box, and if it turns on and behaves normally (other than no audio output), then the internal amp has power--it's just blown.
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,885 Posts
Ok, now we're getting somewhere...what make/model is your aftermarket radio?
 
1 - 15 of 15 Posts
Top