The Nissan Club banner

1 - 11 of 11 Posts

·
Registered
Joined
·
808 Posts
Discussion Starter #1
hey so today i replaced my 2 back stock struts that were blown w/ the KYB-GR2's. The ride is a whole lot better compared to how it used to be, but i still hear a knocking sound when i het the bumps. I am thinking it could be either the strut boots or the bearings!!! :confused:
anyone have any ideas??
 

·
enlarged member
Joined
·
417 Posts
I just did the Eibech/Tokico swap, and the suspension mechanic I took it to (personal friend) wouldn't touch the car until I ordered new STRUT MOUNTS from Nissan, that's that big rubber doughnut that the strut mounts into at the top. The mechanic said that is a wear item & should be replaced with a strut/spring swap. Nissan parts guy said the same thing.

The strut mounts were about $220 ($70 each front, $35 each rear).

The car rides great and no squeeks.
 

·
Haulin' the Family
Joined
·
557 Posts
I added the KYB's to my 100K mile plus Altima. I used the old rubber parts. No problems. No noise either.

For anyone thinking of replacing them yorself. Make sure you get good spring compressor. Like a Crafsman form Sears. And, check to see how your rears are attached under the package shelf. You might need a big-ass allen wrench (at least on SE.) It doesn't show it in the Haynes book (they tore apart a GXE)

-just my 2 cents
 

·
The Saga Continues......
Joined
·
3,303 Posts
when u installed ur springs, did u remember to put the little slips over the ends of the springs that sit on the strut mounts? the sound might be coming from the friction between the spring and the mount. just a thought for ya.
 

·
Registered
Joined
·
808 Posts
Discussion Starter #8
my friend sal put them on for me at his shop. All the necessary tools needed were present. I haven't installed springs yet on my car, im gonna do the next month. I hav driven the car a lot today and have noticed that the nocking sound is def coming from the rear passenger side. i also noticed when i am driving over a bump or bad crease in the road the ride is not as smooth as the drivers side... could it be that only that strut mount is bad and needs to be replaced? could i have blown the strut already??
(?????????????)
 

·
clean freak
Joined
·
3,377 Posts
check your rear sway bar, it could be loose and hitting on the exhaust pipe. Or your exhaust pipe could be lose and it could be hitting the rear sway bar. I had a bad knocking sound and it wound up being the sway bar hitting the exhaust because it was loose.
 

·
Registered
Joined
·
808 Posts
Discussion Starter #10
Thanks everyone for your insight , but I figured out the problem today!
Erynn and i had just gotten back into my car after getting out of the bank, i put the key in and turned and as soon as i heard the engine start and the rumble from my exhaust i heard the knocking sound (coming from the rear passanger side!)
It was sooo funny cause at that exact moment erynn and i looked at eachother ..... i got out made her start the car and sure enough the pipe is knocking against some metal gaurd!he
 
1 - 11 of 11 Posts
Top