The Nissan Club banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
What's up everybody, I remember reading a post earlier about a rotten egg smell people were getting inside the car when they turned on the air conditioning or the heat. My mom who drives the car on a day to day basis is experiencing the same problem. I don't know what it is or if we should take it back to the dealer. Our family recently purchased the Altima about a month ago and I'm not sure if the factory warranty will take care of the problem. Any suggestions to what it is or how to fix it is much appreciated. Thanks again you guys, this forum is very helpfull by the way, very interesting reading. By the way we have a silver 2.5S w/ conv. package with charcoal interior. Bought it for 19,200.
 

·
Registered
Joined
·
57 Posts
Does your car have the in cabin micro filter? If not, I suggest getting one it helps to filter out some odors.
 

·
Consumer Advocate
Joined
·
93 Posts
Taken from this site - http://www.2carpros.com/makes/nissan/altima.htm

Question: 1997 Nissan Altima GXE DOHC 4 cyl mileage: 35,999. Car emits "rotten-egg" smell from exhaust. Is it the CAT or the oxygen sensor?

Answer: The "rotten-egg" smell is caused indirectly by the catalytic converter. The main cause is a rich mixture condition from the engine. Check the catalytic converter to make sure it is not "plugged" or restricted. Your car is equipped with a computer controlled engine management system. An independent auto service center can scan your computer for fault or error codes. The information should pinpoint the mal functioning components.


I have heard of a similar problem with my 95 GMC Jimmy and the catalytic converter was the problem. You might have them check it when you bring it in.
 

·
Registered
Joined
·
3 Posts
Paint/Thinner SMELL

That's what I smell when '02 is cold and first started........
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #6 ·
yeah it has the in cabin micro filter... maybe that's it I don't know but we're gonna take it back to the dealer to get it checked out. Also, it's when it's cold and the car is just started.... seems like a problem other altima owners were having also. Well I'll keep you guys posted as soon as I resolve the problem.
 

·
Hatian Sensation
Joined
·
114 Posts
I just started getting a weird smell when I turn on my AC not sure how to describe it, but I have 11000 miles, could it be the microfilter?
 
1 - 8 of 8 Posts
Top