The Nissan Club banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi experts! Im having an issue with my redtop sr20de.
Basically the only way to have the engine run powerful and reving to the redline without issue, is to rotate the distributor in its slot to the max advance position.
If the position is in the middle, for example, it will struggle and cant go past 5k rpms or so.
The knock sensor is new, reads 0.560 MOhm or 560 KOhm, i checked the wire into it, and i get 4.8V while disconnected.
Redone a portion of the wire with coaxial cable, leaving only the signal wire connected to the sensor.
Checked in the pc the values and all seem fine, not codes, no errors.
The only issue is this, to have it run right, i have to advance as far as i can, and it wont pass emissions this way, have to retard it to around the middle in the distributor slot.
The timing chain is in the right spot on the cams, the gold chainlinks match the dots.
Im out of ideas. What can retard the timing?

Thanks in advance.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Hi, thanks for the reply, i have to look into that, i thought there were no teeth in there!? I mean, i never messed with it and the coupling is direct into the exhaust cam shaft, there is an indentation and no way to change it, but maybe the shaft inside the distributor itself has splices, is that where it is? Still not sure how it explains that when setting timing to around 15º, the distributor is at around the middle position. But i will look into it. Thanks.
 

·
Registered
Joined
·
1,869 Posts
You are right about only being able to plug the unit in half a turn off at a time. Not designed like American engines are.

There has to be something off there to do that, the distributor should be able to be about in the middle of the slot and still be running right.

Cam if it was out may be slightly out of time.

If the wrong wire used off the timing sensor that can retard timing. You mention messing with wiring there, I'd look at that. If there is mechanical advance there I'd be looking to see if it is stuck retarded.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Hi, i looked at it for a while but cant see anything wrong.
Sometimes it seems like there are misfires, when i put my hand feeling the exhaust it seems to skip beats and sound is also not constant.


101326
101327
101328
 
1 - 6 of 6 Posts
Top