The Nissan Club banner

Sad New Member - 2019 Nissan Altima Shuts Off

1335 Views 3 Replies 2 Participants Last post by  amc49
Hey Nissan Club,

I was advised by one of my mechanic friends to come here, so here I am!

I currently have a 2019 Nissan Altima SR with only 22,000 miles. In the past 2 years I have been parked 3 times in random places (drive thru, light, etc), and the entire engine and electronic system goes offline.

There is a SINGLE dim red light on the dash that looks like a P symbol with a red cross over it (to the best of my memory, was my worried about starting it back up and not causing an accident)

It is currently at the dealership under warranty and they say they cannot find any errors within the past 48 hours and all inspections they have done come back OK.

I guess:
1. Has anyone else experienced this? I feel like these new techs just see that there is NO code so they say its good to go.
2. How would you proceed if you were me.. I do not feel safe driving this vehicle that is practically brand new and under 2 warranties (I bought the extra 5k at purchase).


This is my very first car forum so if more info is needed or this needs to be reconciled somewhere else just let me know.

(new battery put in last month because the car wouldn't start)

thanks in advance!
1 - 2 of 4 Posts
I looked at every dash symbol I could find on a '19 and any P meant parking brake but had no X on it........US spec cars.
Yeah it was super DIM and not something you could visibly see while the car was in working condition.

The service manager just called and said they still cannot reproduce issue so I must come pickup the car that is a health and safety issue.

Hopefully this reply bumps the post...I can't be the only one with this issue.
1 - 2 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top