The Nissan Club banner
1 - 20 of 36 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 ·
Dam thing won't go away. The light came on the same day the Stillen header was installed. I reset the computer but it keeps comin back. My brother in law has an obd2 diagnostic computer, so we hooked it up. The code that comes out is- P0420 Catalyst Efficiency Below Threshold (bank 1). Well anyways after checking some stuff, my brother in law thinks that the catalytic converter went bad. So I figure, no problem, time for an upgrade. So then he tries to get some readings from the car while it's running, but the car won't comunicate with the diagnostic comp. It will show the code and pass the tests but it won't show any of the vitals. So he hooks it up to my sister's civic and the comp works fine. He can see all the numbers that the sensors are sending. Everything from voltage to the timing. He hooks it to my car and gets nothing.
He sais the obd2 computers are the same from car to car, so something is wrong with my computer. So I figure I'm screwed cause I can't take it to the dealer. They are just gonna fuck me over. I'm sure the warranty is not gonna cover it cause of the header and all the mods I've done. So I'm not sure what to do rite now. Maybe it's just the cat that needs to be replaced. Atleast I hope thats all it is.
So what are signs that the cat has gone bad? He explained to me why he thaught it was the cat, but it kinda went over my head.
Ok, thats enough typing. Any help appreciated.

Osama, did the light go away?
 

·
Registered
Joined
·
1,083 Posts
is the car running fine? if it is..forget about it. my light came on ever since i put in my cai. i went to nissan, paid them $60 to do the diagnostic test and they told me it was my rims..uh..ok..wtf huh. my car has been running fine. the idle is good so i dont care if the light is on.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #3 ·
Yeah, It maybe nothing. But it's bugging me. I don't want to have any problems with this car. I may have to rethink this whole mod thing. I don't want to ruin a perfectly good car that is not even completely paid for.
 

·
350Z
Joined
·
5,899 Posts
Havik 2K said:
Yeah, It maybe nothing. But it's bugging me. I don't want to have any problems with this car. I may have to rethink this whole mod thing. I don't want to ruin a perfectly good car that is not even completely paid for.
I thought the same thing, but it can't be your computer. We both have the same problem and both our service people told us its the cat, we both have a stock one, its got to be that.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #6 ·
osama said:


I thought the same thing, but it can't be your computer. We both have the same problem and both our service people told us its the cat, we both have a stock one, its got to be that.
Well I just got my IRS check today. I guess I'll spend some of it on the cat. Is it gonna get louder? My shit is loud! And I have the stock resonator on.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #8 ·
Someone told me it sounded like one of those raced out crx's. That loud raspy sound. Hope I don't get pulled over for it. I allready gotta remove my tint cause I got pulled over for speeding, and the fix it ticket included.
 

·
Registered
Joined
·
1,323 Posts
Is the light constantly on?
osama, I'm about to PM you.
Jay
 

·
350Z
Joined
·
5,899 Posts
hey Thurznite, my light turned on like 4-6 hours after header install. It has been on since, never went out.
About that pm, I think you should send it to Havik_2k, I tried to reply and your inbox is full.
 

·
jdm b16a eg6/MeCCaRyDeR
Joined
·
5,017 Posts
dont you got a o2 sensor in your cat?!?!?..check if thats gone...when i took out my cat...my check came on...but then some guy told me to wrap warm wet cloth around it....so i did..and no more check engine
 
G

·
ZKrazy said:
i went to nissan, paid them $60 to do the diagnostic test and they told me it was my rims..uh..ok..wtf huh.

damn, the dealer sucks. how in the hell does rims make the check engine lite come on??? fucking idiots.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #20 ·
MeCCaRyDeR said:
dont you got a o2 sensor in your cat?!?!?..check if thats gone...when i took out my cat...my check came on...but then some guy told me to wrap warm wet cloth around it....so i did..and no more check engine
I don't think it has one on the cat. So far I've only seen two. One one the header and the other on the downpipe.
 
1 - 20 of 36 Posts
Top