The Nissan Club banner

1 - 11 of 11 Posts

·
Die Trying
Joined
·
8,357 Posts
Discussion Starter #1
after 4 passes at the track with slicks, somethin went wrong on the last pass. for starters, i had a shitty launch, and as if that wasn't enough, n2o stopped sprayin shortly after 1st-2nd shift. not sure what it could be.

i do know that it's got to be something with the nitrous system. the car still runs hard/good without it. so, i'm guessing it's a leak, or blown solenoid, etc. I'll check it out tomorrow, but suggestions are always welcome

anyone?
thanks in advice
 

·
Turbo Motorhead
Joined
·
3,466 Posts
Sorry to hear the news 1fast. :( I was also thinking about bottle pressure as well in terms of a LEAK. YIKES!!! If you already haven't done so, check all your N2O connections.

Assuming your nitrous kicks in on full throttle, check out the connection b/t the 'open' switch (called by a lot of names) and throttle area linkage. Something may not be making proper contact anymore when you're full throttle.
 

·
Die Trying
Joined
·
8,357 Posts
Discussion Starter #4
i do have bottle pressure. i remember seeing it when i closed the bottle after i got home. that must meant that:

bottle
feed line to solenoid
connection into solenoid

are ok. it's gotta be somewhere after that, right? i'm thinking a blown solenoid, or my nozzle fell out of place or something.

funny thing is that when i do try to use it (and it doesn't work) i can feel it like it wants to work. i get the slightest little spirts of power. so that makes me think there's a clog in the line somewhere

keep em comin
 

·
My Alti got da last laugh
Joined
·
1,546 Posts
try this. disconnect your fogger from intake and do something like a purge. disconnect you full throttle or have some one hold it at full throttle and have them hit the switch and spray into the air, see if it sprays well, if not start you way back from there like disconnect before solenoid and open bottle and see if you got nitous going to solenoid and maybe disconnect fogger and see if nitrous spray from line. you might have a bad fogger or jet or something.
 

·
105hp OWNS
Joined
·
391 Posts
Okay from WHAT I HEARD again I say from WHAT I HEARD. Running that amount a pressure (1200) is not good for the solenoid. They say that is near the point where it wont open FROM WHAT IVE HEARD. Im going to put my money on a Broken solenoid. When you replace that solenoid it may hurt your time some but I would only run 1100 psi in the line. Also if it is a broken solenoid your lucky it didnt get stuck open. Sorry to hear what happened, hehe I guess I didnt jog all the way to your car for nothing. Let me know if there is anything I can do to help.
 

·
Die Trying
Joined
·
8,357 Posts
Discussion Starter #9
well, i've pretty much decided it's the nitrous solenoid. I checked all the lines, the nozzle (in the intake), bottle pressure. everything is straight, it just won't spray. So, i'm thinking blake's right, i just had too much pressure on a hot day. I've already priced them and they're $100! I guess that's peanuts compared to what i've already put into the car, but it's still an $100 i don't have right now. Ah well. Like i said, as of now, i'm gonna say it's the solenoid, but i'll look into it further in a few days when i can talk to some nitrous experts around here.

thanks guys for all the suggestions. I'll be up n runnin soon enough

good thing is, at least i can drive it. it's just nitrous related.
 

·
My Alti got da last laugh
Joined
·
1,546 Posts
you have nitrous before the solenoid right. and did you try spraying into the air and it didnt work. then if you did that bad solenoid i guess. i didnt think that 1200 psi would destroy a solenoid(ive shot at 1100-1200 before), maybe more would do it but your bottle would dump the nitrous first. i think quick97 runs his bottle at 1100-1200 most of the time.
 

·
Die Trying
Joined
·
8,357 Posts
Discussion Starter #11
i do it all the time too, maybe it just finally had it, ya know. not that it was just this one time, it might have had a strain the entire time and it finally couldn't handle it anymore
 
1 - 11 of 11 Posts
Top