The Nissan Club banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Good Afternoon Nissan Owners,
I joined your website to see if anyone can help me out. When driving my Nissan Altima 3.5 VQ35DE there is a loud squeak whenever I drive. Similar to the bike that Deebo rode in the movie "Friday." I already replaced the brake pads as I presumed it would've been expired brakes rubbing against the caliper. I recently replaced my passenger CV Axle and I believe that to be the problem as it isn't an OEM part but a DURALAST part from AutoZone.

Has anyone experienced a similar problem?
 

·
09 Altima 3.5SE 6MT Sedan
Joined
·
6,365 Posts
I assume the noise comes from the front of the vehicle and sounds like brake squeal?

You can block the rear wheels, jack up one side of the front until the drive wheel is off the ground. Start the vehicle, and with foot on the brake put it in D, gingerly let up on the brake pedal and the suspended wheel should start to rotate, see if you can isolate the squeal to one side or the other. Then remove the brake pads from the side that is squealing...if the noise persists, it pretty much has to be the bearing, or, if on the passenger side, it could be the carrier bearing on the CV shaft.
 

·
Registered
Joined
·
1 Posts
Hi, I replaced the passenger axle (Rogue 2012) andnow I am hearing the squealing noise (after 20 min driving and happens randomly!). It took 2 hours to remove the old axle as it was stuck in its aluminum carrier. Could the carrier make a noise like that?
I also changed the CVT fluid and worried that this noise is coming from CVT. Any idea to find the source of the noise? Thanks
 
1 - 4 of 4 Posts
Top