The Nissan Club banner

1 - 20 of 25 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi Everyone,

I have a 1995 Nissan Altima. When I purchased the car the gentleman told me to remember to have my timing belt replaced at 90,000 miles. The automotive repair shop is telling me that the car has a timing chain. Does anyone know if the 95 Altima has a belt or chain?

Thanks!
 

·
H.N.I.C.
Joined
·
2,666 Posts
welcome to the sight...

around 95-110k miles u will start to hear this *clink clink clink* noise from the pulley area...
that is the timing chain...
your car won't be broke, every KA24DE does it...
just deal wit it, cause it'll cost the price of a new engine...
now if the sound get louder n worse n schreechy, that is your A/C pulley most likely...
happened to me..
cost like $200 to get fixed...
 

·
Resistance is futile
Joined
·
1,713 Posts
Is "PC" for "Personal Computer" or "Politically Correct"?
 

·
Registered
Joined
·
15 Posts
Since you guys mention about timing chain, perhaps can assist to clear my doubts. My 96 ALty (A) SR20DE has some 'diesel engine' type of noise during first start-up of the day or when then engine is not hot. THe noise will only be there for about 3-5 seconds and then it's gone. THe mechanics told me it is because of the timing chain tension. Either to high or low....HELP
 

·
Registered
Joined
·
1,108 Posts
tengster said:
Since you guys mention about timing chain, perhaps can assist to clear my doubts. My 96 ALty (A) SR20DE has some 'diesel engine' type of noise during first start-up of the day or when then engine is not hot. THe noise will only be there for about 3-5 seconds and then it's gone. THe mechanics told me it is because of the timing chain tension. Either to high or low....HELP
I think that's wrong. To me it sounds like an ignition problem, or perhaps a flaky injector.
 

·
Registered
Joined
·
15 Posts
Kenshi: What make you think it's a flaky injector. WHen the engine is warm and off, then I try to start it up, the noise won't appear. It happen only during cold start-up.

Cold = ambient temperature.....not winter. Coz Malaysia weatheris about 30C+- all year long.
 

·
Registered
Joined
·
1,108 Posts
tengster said:
Kenshi: What make you think it's a flaky injector.
I said it might be a flaky injector. . The reason I thought of the injector is that it sounds like all cylinders aren't firing on a cold start and a bad injector is one reason that would happen, however I would look at the ignition system first.

Is your engine in good repair, up to date on scheduled maintenance?
 

·
Resistance is futile
Joined
·
1,713 Posts
So is this a clatter sound, like something beating on the inside of the valve cover?
 
1 - 20 of 25 Posts
Top