The Nissan Club banner

1 - 9 of 9 Posts

·
Registered
Joined
·
530 Posts
Discussion Starter #1
hey guys i had a quick question, i know i should search for this but i gotta get to work here in a few so i was wondering if someone could help me out real quick. my car makes this weird noise in the back when i go over bumps....it sounds like something is just loose, i have had my rear stabelizers (or whatever) replaced and i just had sprints and KYB's installed so its not any of that. do u guys have any suggestions? anything to look for or check? it doesn't sound to me like its doing any damage but i've had this problem since i got the car and could just never figure out what it was.....i usually just turn the music up to avoid it :) any help would be appreciated.....thanks!
 

·
Qµì¢K L£ã®Ñ€r
Joined
·
541 Posts
yeah i know i have the same noise. Check your anti sway bar, the bushings and the connections. And Peterson said once some part of the cat piping might be hitting the car chassies. not really sure cause my sound just went away after i installed my tokicos. weird.
 

·
Registered
Joined
·
530 Posts
Discussion Starter #3
i dont think anything is hitting anywhere.....although it makes the noise over the slightest bumps......defineately sounds like a rattle (something loose) i'll check the sway bar thing though :)
 

·
Registered
Joined
·
530 Posts
Discussion Starter #6
might be....should i get a stillen one if the sway bar is the problem?
 

·
Registered
Joined
·
530 Posts
Discussion Starter #9
thanks man.....i'll check that out tomorrow :)
 
1 - 9 of 9 Posts
Top