The Nissan Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2011 Nissan Altima, just recently it started making a whining noise that happens whether I’m in park, reverse, neutral or drive. It only happens when a bit when I crank the car cold, then goes away once the idle goes down, if I drive the car, the further the rpms go up the louder the noise gets, when It shifts the noise goes back down as the rpms do, to me it seems like a vacuum issue, I checked the intake, that’s in perfect condition, so I’m pretty clueless as to where the sound could be coming from, maybe a vacuum hose or something. Please tell me what you think
 

·
Registered
Joined
·
2 Posts
I have a 2011 Nissan Altima, just recently it started making a whining noise that happens whether I’m in park, reverse, neutral or drive. It only happens when a bit when I crank the car cold, then goes away once the idle goes down, if I drive the car, the further the rpms go up the louder the noise gets, when It shifts the noise goes back down as the rpms do, to me it seems like a vacuum issue, I checked the intake, that’s in perfect condition, so I’m pretty clueless as to where the sound could be coming from, maybe a vacuum hose or something. Please tell me what you think
Ssa
 

·
Registered
Joined
·
2 Posts
Sadly it’s your CVT I have a 2012 and had the exact problem drove me crazy. Months later the CVT failed. I would recommend changing the fluid immediately. Sorry to say you will honestly probably have to replace it. I did and it cost me 3500$. Best of luck. I actually just serviced mine a couple days ago. I’m praying I didn’t mess up. Also I used valvoline CVT fluid I hope to god I didn’t mess up there. But it’s rated #1. If you end up replacing it change the Fluid every 15k or install a aftermarket intercooler.
Best of luck man. I’m just writing this from my personal experience and the fact that that CVT has known issues yet nissian doesn’t care
 
1 - 3 of 3 Posts
Top