The Nissan Club banner

1 - 5 of 5 Posts

·
Cube Farmer
Joined
·
2,202 Posts
Discussion Starter #1
Ya, they are stuck in the "up" position. Came out to run to the store today, scrape all the ice and snow off (we got 8" last nite) and i turn the wipers on. They wipe once or twice and then they stay stuck in the middle of the windshield. I was a dumb ass and checked all the fuses before i realized i still heard the wiper motor still running, but its obviously not driving the wipers anymore. I tried to move the wipers down with my hands and the bastards are stuck. I havent had time to pull the plastic shields off to take a look under them yet (not to mention they are half frozen on) but anyone else have this problem? I already took a look at wiper motor costs ($70 ouch) because im guessing i stripped something. Not to mention there is this weird diffrence on the auto zone website... the motor costs $70 if your car was built before 4/94 and costs $40 if it was built after, strange..
 

·
Banned
Joined
·
117 Posts
It happens. Most likely the arms got disconnected from the wiper motor lever, it can't be stripped... there is too much metal - the lighter part is the plastic bushing on the arms. If motor is running - it shouldn't be bad. Make sure to lubricate the bushings when installing again.
 

·
Registered
Joined
·
424 Posts
This sort of happened with my NX2000 before... except I could still move the wipers. It was the arm connected to the wiper motor. I just replaced the arm. It was only about $20 CAN. Not too much trouble to do on your own.

I concur with Inoplanet.

Hope it works out for ya.

Stan
 
1 - 5 of 5 Posts
Top